Import Data & Export Tool

Aqua Data Studio's Import-Export tool allows you to transfer data and perform load operations between a database and external files. Importing data and exporting it to different file formats, file encoding and OS platforms are supported. Exports may be performed on a single table or complex SELECTs on multiple tables. The Import/Export tool offers features to optimize performance of data load operations on production databases. Options selected in the Import/Export CSV Dialog can be saved and reused with the auto generated scripts using Open APIs. Import data directly from CSV or Excel files.



Aqua Data Studio Import Data & Export Tool includes the following functions:

Data Import

The Aqua Data Studio Import Tool allows users to import data into database table objects. Data importing can be started by selecting Tools->Import Data from the File Menu or right clicking on the table you want to import and selecting Tools->Import Data.data import screenshots Data Import

Import from different File formats, Encoding and Platform

Import data directly from Excel files or text files. Text files support CSV format with different encodings, such as UTF-8, UTF-16, ASCII, SJIS. For text files, choose between OS Platform specific Windows Style End of Line (CR/LF) or Unix Style End of Line (LF). data import encoding screenshots Data Import - Encoding | Data Import - Excel

Flexible Import Options for Source file

The Import->General tab displays the contents of the source file under Sample File Columns. For text files, you can choose the column separator or specify a Fixed Column Width. For Excel files, you can choose to import one or more worksheets. The data types of the table are automatically selected in the Format tab. Several Data Options like NULL value imported for "null" string and formatting for Date, Time and Number are also available. data import format screenshots Data Import - Format | Data Import - Excel Multiple Worksheets

Create Tables within Import Dialog

Use the Import->Format tab to create a new database table and import your data with a few keystrokes. This feature helps you to quickly create a table that matches your data within the Import dialog itself.data import - create table screenshots Data Import - Create Table

Import Performance Optimizations

Speed up the import process with the Transaction option which offers three different modes - Full, Batch and Threshold. Full Mode executes commits after each row of data. With the Batch Mode import is faster as commits are executed after a specified number of records. Threshold Mode executes commits at specified time intervals. The Wait Time determines the amount of time to wait between transactions and throttles down import speed but reduces load when Import Tool is used on production databases.data import - transaction options screenshots Data Import - Transaction Options

Import Data Preview and Status Monitor

Data Import tool enables preview of the Insert statements before it is imported into the database table under the Options tab->Destination->Preview INSERT statements/Save INSERT statements into file. Another feature is the Status tab which displays real time import progress and statistics such as Time Elapsed / Remaining, Number of Rows Imported, Rows per Second and Average Time per Row.data import - preview INSERT statements screenshots Data Import - Preview INSERT Statements

Data Export

The Aqua Data Studio Export Tool allows users to export data from single or multiple database table or view objects to files. Exporting data can be initiated by selecting Tools->Export Data from the File Menu or right clicking on the table or view you want to export and selecting Tools->Export Data.data export screenshots Data Export

Export to different File formats, Encoding and Platforms

Export data for data migration to popular formats such as Excel 2003/2007, CSV, XML and with different Encoding such as UTF-8, UTF-16, ASCII, SJIS. OS Platform specific Windows Style End of Line (CR/LF) and Unix Style End of Line (LF) are also supported.Data Export - Excel 2007 Format screenshots Data Export - Excel 2007 Format

Flexible Export Options for Tables

The Export->General tab displays the list of tables and views of the selected Database. You can select a single object or multiple objects to export. When exporting multiple objects, export data is placed into a number of files in the folder specified by the user, one file per each table or view object. You can select the column separators under Options->Data Format->Delimiter. The String and Date quoted identifier can be selected in the Options tab. Several Data Options like Include Columns as First Row and Set text to (null) on NULL value and formatting for Date, Time and Decimal Symbol are also available. Data Export - Format Options screenshots Data Export - Format Options

Export from SELECT statements

Export can be done based on a complex SELECT statement including multiple tables.Data Export - Export from Select Statements screenshots Data Export - Export from Select Statements

Export Status Monitor

The Status tab displays real time export progress and any warnings or errors in the message text window as the export proceeds.data export - status screenshots Data Export - Status

Generate AquaScript for Open API development

The selected CSV Import or Export Options can be saved and reused with the Generate AquaScript feature. Using AquaScripts — a JavaScript-based programming language — you can build routines for exporting data and importing CSV data between databases and the local file system. Aqua Open APIs include functions for reading and writing data to database table objects as well as accessing popular CSV, HTML and Excel file formats. Scripts can be developed and debugged using Aqua Data Studio and deployed to Aqua Data Server, resulting in fast, efficient and customized data management.data export - generate AquaScript screenshots Data Export - Generate AquaScript

Home Aqua Data Studio Aqua Data Server AquaClusters Support Buy Company Privacy

Copyright © 2001–2017 AquaFold, Inc. All Rights Reserved.